A.S.C Filtre, Grafik ve Raporlama Eklentisi

[FORM] Resim problemi
#1
Access 2010 ile yapılan programda, program çalışırken fotolar formda gözüküyor. Ancak acces runtime 2016 yı kurduğumda formlarda fotolar görülmüyor. Program kısmındaki ifadeler "Resim1 = sunucu & "\foto\personel\" & "" & Kod & ".JPG"
Me.cerceve.Picture = Resim1" şeklindedir. Bu problemi nasıl aşarım.



  Alıntı
Bu mesajı beğenenler:
#2
Sn alienerji;

Visual Basic
  1. Private sub Form_current()
  2. if len(dir("\\SunucuAdi\foto\personel\" & Kod &".jpg",vbnormal))>0 then
  3. Me.cerceve.Picture ="\\SunucuAdi\foto\personel\" & Kod &".jpg"
  4. else
  5. Me.cerceve.Picture ="\\SunucuAdi\foto\personel\Yok.jpg"
  6. end if
  7. end sub



Sunucu \foto\personel klasorunde yok.jpg oldugu varsayimi ve SunucuAdi yerine kendi sunucu adini yazabilirsiniz.



  Alıntı
Bu mesajı beğenenler:
#3
Sayın Dsezgin Access 2010 çalışıp ta Access runtime 2016 çalışmama problemi yine kodları değiştirdiğim halde devam etti. Bendeki problem access 2010 da eğer personel resmi varsa gösteriyor, yoksa resimyok.jpg dosyasının resmini gösteriyor. Yani beyaz boş bir foto gösteriyor. Bu sefer runtime2016 ya geçince bu fotolar forma gelmiyor. (Hem boş foto hemde personel fotosu) Access 2010 daki kodlarım aşağıdaki şekildeki gibidir:
Dim Kod As String
Kod = Me.kullanici
Resim1 = sunucu & "\foto\personel\" & "" & Kod & ".JPG"
Me.cerceve.Picture = Resim1
Exit_hata:
Exit Sub
hata:
Resim1 = sunucu & "\foto\personel\resimyok.jpg"
Me.cerceve.Picture = Resim1
Resume Exit_hata
End sub



  Alıntı
Bu mesajı beğenenler:
#4
Access 2016 ile yeni dosya olusturup, form ile nesne olusturun, kodu tasima ile olayini runtime2016 ile test edebilirsiniz.

Resim1 = "\\" & sunucu & "\foto\personel\" & Kod & ".jpg"

sunucu degiskeni onunde "\\" isareti olmasi gerekir. Yukarida ki satiri deneyebilirsiniz.



  Alıntı
Bu mesajı beğenenler:
#5
Sayın dsezgin, sunucu ibaresi //197.98.76... gibi bir yerel ip ile eşlestirildiğinden sunucu kelimesinin önüne // koyulunca doğrudan hata veriyor. Yanı eleştirmese zaten ibarenin başında// işareti baştan var olduğundan ////şeklinde fazla ifade hatası veriyor.  Dolayısıyla problem çözülmedi. 2016 acces te formu tekrar tasarlama tavsiyenizi henüz yapamadım. Ilk fırsatta onu da deneyeceğim.



  Alıntı
Bu mesajı beğenenler:
#6
Resim1 = & sunucu & "\\foto\\personel\\" & Kod & ".jpg"
şeklinde deneyin



  Alıntı
Bu mesajı beğenenler:


Benzer Konular...
Konu: Yazar Cevaplar: Gösterim: Son Mesaj
  Tablo Bağlama Problemi alienerji 8 190 17-01-2020, 01:13
Son Mesaj: alienerji
  [RAPOR] Raporda Resim Gösterimi husem 4 184 26-11-2019, 14:48
Son Mesaj: husem
  Liste Kutusu Aktarma Ve Rapor Problemi sefersanli 8 115 19-11-2019, 09:05
Son Mesaj: halily
  Liste Kutusu Aktarma Ve Rapor Problemi sefersanli 13 356 18-11-2019, 22:07
Son Mesaj: sefersanli
  Fareyi Resim üzerine Taşıyıp Resmi Büyütmek M_Kemal_Askeri 5 218 29-09-2019, 06:49
Son Mesaj: dsezgin
  [FORM] Seçenek Grubu Problemi hersey 15 1.148 25-06-2019, 15:21
Son Mesaj: HilalAccess
  [MAKRO] form a otomatik resim ekleme ccollezium 13 753 20-05-2019, 15:48
Son Mesaj: AErsinA
  [FORM] Form Butonlarından Resim Yada Iconları Dışa Aktarmak junaid 6 335 08-05-2019, 04:36
Son Mesaj: dsezgin

Foruma Git:


Bu konuyu görüntüleyen kullanıcı(lar): 1 Ziyaretçi